| Package | Affected versions | Patched versions |
|---|---|---|
| rubygems-update | < 0.9.1 | 0.9.1 |
| rubygems | = 0.8.11≤ 0.9.0 |
The extract_files function in installer.rb in RubyGems before 0.9.1 does not check whether files exist before overwriting them, which allows user-assisted remote attackers to overwrite arbitrary files, cause a denial of service, or execute arbitrary code via crafted GEM packages.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free