In breve
- CVE-2021-41186 è una vulnerabilità ALTO (CVSS 7.5) che riguarda fluentd, fluentd (fluentd).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 2.2%, superiore al 82.6% delle vulnerabilità.
- Correzione: aggiornare a 1.14.2 o successiva.
| Package | Affected versions | Patched versions |
|---|
| fluentd RubyGems | ≥ 0.14.14, < 1.14.2
| 1.14.2
|
| fluentd | ≥ 0.14.14, ≤ 1.14.1
| No fix yet |
Description
Impact
parser_apache2 plugin in Fluentd v0.14.14 to v1.14.1 suffers from a regular expression denial of service (ReDoS) vulnerability. A broken apache log with a certain pattern of string can spend too much time in a regular expression, resulting in the potential for a DoS attack.
Patches
v1.14.2
Workarounds
Either of the following:
- Don't use parser_apache2 for parsing logs which cannot guarantee generated by Apache.
- Put patched version of parser_apache2.rb into /etc/fluent/plugin directory (or any other directories specified by the environment variable
FLUENT_PLUGIN or --plugin option of fluentd).
References
NVD description
Fluentd collects events from various data sources and writes them to files to help unify logging infrastructure. The parser_apache2 plugin in Fluentd v0.14.14 to v1.14.1 suffers from a regular expression denial of service (ReDoS) vulnerability. A broken apache log with a certain pattern of string can spend too much time in a regular expression, resulting in the potential for a DoS attack. This issue is patched in version 1.14.2 There are two workarounds available. Either don't use parser_apache2 for parsing logs (which cannot guarantee generated by Apache), or put patched version of parser_apache2.rb into /etc/fluent/plugin directory (or any other directories specified by the environment variable `FLUENT_PLUGIN` or `--plugin` option of fluentd).
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free