In breve
- CVE-2022-39379 è una vulnerabilità CRITICO (CVSS 9.8) che riguarda fluentd, fluentd (fluentd).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 45.0%, superiore al 98.8% delle vulnerabilità.
- Correzione: aggiornare a 1.15.3 o successiva.
| Package | Affected versions | Patched versions |
|---|
| fluentd RubyGems | ≥ 1.13.2, < 1.15.3
| 1.15.3
|
| fluentd | ≥ 1.13.2, < 1.15.3
| 1.15.3
|
Description
Impact
A remote code execution (RCE) vulnerability in non-default configurations of Fluentd allows unauthenticated attackers to execute arbitrary code via specially crafted JSON payloads.
Fluentd setups are only affected if the environment variable FLUENT_OJ_OPTION_MODE is explicitly set to object.
Please note: The option FLUENT_OJ_OPTION_MODE was introduced in Fluentd version 1.13.2. Earlier versions of Fluentd are not affected by this vulnerability.
Patches
v1.15.3
Workarounds
Do not use FLUENT_OJ_OPTION_MODE=object.
References
NVD description
Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. A remote code execution (RCE) vulnerability in non-default configurations of Fluentd allows unauthenticated attackers to execute arbitrary code via specially crafted JSON payloads. Fluentd setups are only affected if the environment variable `FLUENT_OJ_OPTION_MODE` is explicitly set to `object`. Please note: The option FLUENT_OJ_OPTION_MODE was introduced in Fluentd version 1.13.2. Earlier versions of Fluentd are not affected by this vulnerability. This issue was patched in version 1.15.3. As a workaround do not use `FLUENT_OJ_OPTION_MODE=object`.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free