In breve
- CVE-2022-28730 è una vulnerabilità MEDIO (CVSS 6.1) che riguarda org.apache.jspwiki:jspwiki-main, jspwiki (apache).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 86.2%, superiore al 99.7% delle vulnerabilità.
- Correzione: aggiornare a 2.11.3 o successiva.
Description
A carefully crafted request on AJAXPreview.jsp could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. This vulnerability leverages CVE-2021-40369, where the Denounce plugin dangerously renders user-supplied URLs. Upon re-testing CVE-2021-40369, it appears that the patch was incomplete as it was still possible to insert malicious input via the Denounce plugin. Apache JSPWiki users should upgrade to 2.11.3 or later.
NVD description
A carefully crafted request on AJAXPreview.jsp could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. This vulnerability leverages CVE-2021-40369, where the Denounce plugin dangerously renders user-supplied URLs. Upon re-testing CVE-2021-40369, it appears that the patch was incomplete as it was still possible to insert malicious input via the Denounce plugin. Apache JSPWiki users should upgrade to 2.11.3 or later.
Altre vulnerabilità di org.apache.jspwiki:jspwiki-main
Vedi tutto →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free