In breve
- CVE-2022-39340 è una vulnerabilità MEDIO (CVSS 5.3) che riguarda github.com/openfga/openfga, openfga (openfga).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.91%, superiore al 59.9% delle vulnerabilità.
- Correzione: aggiornare a 0.2.4 o successiva.
Description
Overview
During our internal security assessment, it was discovered that streamed-list-objects endpoint was not validating the authorization header resulting in the disclosure of objects in the store.
Am I Affected?
You are affected by this vulnerability if you are using openfga/openfga version v0.2.3 or prior and you are exposing the OpenFGA service to the internet.
How to fix that?
Upgrade to version v0.2.4.
Backward Compatibility
This update is backward compatible.
NVD description
OpenFGA is an authorization/permission engine. Prior to version 0.2.4, the `streamed-list-objects` endpoint was not validating the authorization header, resulting in disclosure of objects in the store. Users `openfga/openfga` versions 0.2.3 and prior who are exposing the OpenFGA service to the internet are vulnerable. Version 0.2.4 contains a patch for this issue.
Altre vulnerabilità di github.com/openfga/openfga
Vedi tutto →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free