In breve
- CVE-2023-30608 è una vulnerabilità ALTO (CVSS 7.5) che riguarda sqlparse, sqlparse (sqlparse project).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.98%, superiore al 62.4% delle vulnerabilità.
- Correzione: aggiornare a 0.4.4 o successiva.
| Package | Affected versions | Patched versions |
|---|
| sqlparse PyPI | ≥ 0.1.15, < 0.4.4
| 0.4.4
|
| sqlparse | ≥ 0.1.15, < 0.4.4
| 0.4.4
|
Description
Impact
The SQL parser contains a regular expression that is vulnerable to ReDoS (Regular Expression Denial of Service). The vulnerability may lead to Denial of Service (DoS).
Patches
This issues has been fixed in sqlparse 0.4.4.
Workarounds
None.
References
This issue was discovered and reported by GHSL team member @erik-krogh (Erik Krogh Kristensen).
- Commit that introduced the vulnerability: e75e35869473832a1eb67772b1adfee2db11b85a
NVD description
sqlparse is a non-validating SQL parser module for Python. In affected versions the SQL parser contains a regular expression that is vulnerable to ReDoS (Regular Expression Denial of Service). This issue was introduced by commit `e75e358`. The vulnerability may lead to Denial of Service (DoS). This issues has been fixed in sqlparse 0.4.4 by commit `c457abd5f`. Users are advised to upgrade. There are no known workarounds for this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free