In breve
- CVE-2023-49566 è una vulnerabilità ALTO (CVSS 8.8) che riguarda org.apache.linkis:linkis-datasource, linkis (apache).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.84%, superiore al 58.1% delle vulnerabilità.
- Correzione: aggiornare a 1.6.0 o successiva.
Description
In Apache Linkis <=1.5.0, due to the lack of effective filteringof parameters, an attacker configuring malicious db2 parameters in the DataSource Manager Module will result in jndi injection. Therefore, the parameters in the DB2 URL should be blacklisted.
This attack requires the attacker to obtain an authorized account from Linkis before it can be carried out.
Versions of Apache Linkis <=1.5.0 will be affected. We recommend users upgrade the version of Linkis to version 1.6.0.
NVD description
In Apache Linkis <=1.5.0, due to the lack of effective filtering
of parameters, an attacker configuring malicious
db2
parameters in the DataSource Manager Module will result in jndi injection. Therefore, the parameters in the DB2 URL should be blacklisted.
This attack requires the attacker to obtain an authorized account from Linkis before it can be carried out.
Versions of Apache Linkis
<=1.5.0
will be affected.
We recommend users upgrade the version of Linkis to version 1.6.0.
Altre vulnerabilità di org.apache.linkis:linkis-datasource
Vedi tutto →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free