In breve
- CVE-2024-31452 è una vulnerabilità CRITICO (CVSS 9.8) che riguarda github.com/openfga/openfga, openfga (openfga).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.66%, superiore al 51.4% delle vulnerabilità.
- Correzione: aggiornare a 1.5.3 o successiva.
Description
Overview
Some end users of OpenFGA v1.5.0 or later are vulnerable to authorization bypass when calling Check or ListObjects APIs.
Am I Affected?
You are very likely affected if your model involves exclusion (e.g. a but not b) or intersection (e.g. a and b) and you have any cyclical relationships. If you are using these, please update as soon as possible.
Fix
Update to v1.5.3
Backward Compatibility
This update is backward compatible.
NVD description
OpenFGA is a high-performance and flexible authorization/permission engine. Some end users of OpenFGA v1.5.0 or later are vulnerable to authorization bypass when calling Check or ListObjects APIs. You are very likely affected if your model involves exclusion (e.g. `a but not b`) or intersection (e.g. `a and b`). This vulnerability is fixed in v1.5.3.
Altre vulnerabilità di github.com/openfga/openfga
Vedi tutto →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free