In breve
- CVE-2024-42468 è una vulnerabilità ALTO (CVSS 7.5) che riguarda org.openhab.ui.bundles:org.openhab.ui.cometvisu, openhab (openhab).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.81%, superiore al 57.0% delle vulnerabilità.
- Correzione: aggiornare a 4.2.1 o successiva.
Description
openHAB's CometVisuServlet is susceptible to an unauthenticated path traversal vulnerability.
Local files on the server can be requested via HTTP GET on the CometVisuServlet.
This vulnerability was discovered with the help of CodeQL's Uncontrolled data used in path expression query.
Impact
This issue may lead to Information Disclosure.
NVD description
openHAB, a provider of open-source home automation software, has add-ons including the visualization add-on CometVisu. CometVisuServlet in versions prior to 4.2.1 is susceptible to an unauthenticated path traversal vulnerability. Local files on the server can be requested via HTTP GET on the CometVisuServlet. This issue may lead to information disclosure. Users should upgrade to version 4.2.1 of the CometVisu add-on of openHAB to receive a patch.
Altre vulnerabilità di org.openhab.ui.bundles:org.openhab.ui.cometvisu
Vedi tutto →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free