In breve
- CVE-2025-24887 è una vulnerabilità MEDIO (CVSS 6.3) che riguarda pycti, opencti (citeum).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.26%, superiore al 17.3% delle vulnerabilità.
- Correzione: aggiornare a 6.4.11 o successiva.
| Package | Affected versions | Patched versions |
|---|
| pycti PyPI | ≥ 6.4.9, < 6.4.11
| 6.4.11
|
| opencti | > 6.4.8, ≤ 6.4.10
| No fix yet |
Description
OpenCTI is an open-source cyber threat intelligence platform. In versions starting from 6.4.8 to before 6.4.10, the allow/deny lists can be bypassed, allowing a user to change attributes that are intended to be unmodifiable by the user. It is possible to toggle the external flag on/off and change the own token value for a user. It is also possible to edit attributes that are not in the allow list, such as otp_qr and otp_activated. If external users exist in the OpenCTI setup and the information about these users identities is sensitive, the above vulnerabilities can be used to enumerate existing user accounts as a standard low privileged user. This issue has been patched in version 6.4.10.
NVD description
OpenCTI is an open-source cyber threat intelligence platform. In versions starting from 6.4.8 to before 6.4.10, the allow/deny lists can be bypassed, allowing a user to change attributes that are intended to be unmodifiable by the user. It is possible to toggle the `external` flag on/off and change the own token value for a user. It is also possible to edit attributes that are not in the allow list, such as `otp_qr` and `otp_activated`. If external users exist in the OpenCTI setup and the information about these users identities is sensitive, the above vulnerabilities can be used to enumerate existing user accounts as a standard low privileged user. This issue has been patched in version 6.4.10.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free