In breve
- CVE-2025-27553 è una vulnerabilità ALTO (CVSS 7.5) che riguarda org.apache.commons:commons-vfs2, commons vfs (apache).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 1.4%, superiore al 73.0% delle vulnerabilità.
- Correzione: aggiornare a 2.10.0 o successiva.
Description
Relative Path Traversal vulnerability in Apache Commons VFS before 2.10.0.
The FileObject API in Commons VFS has a 'resolveFile' method that
takes a 'scope' parameter. Specifying 'NameScope.DESCENDENT' promises that "an exception is thrown if the resolved file is not a descendent of
the base file". However, when the path contains encoded ".."
characters (for example, "%2E%2E/bar.txt"), it might return file objects that are not
a descendent of the base file, without throwing an exception.
This issue affects Apache Commons VFS: before 2.10.0.
Users are recommended to upgrade to version 2.10.0, which fixes the issue.
NVD description
Relative Path Traversal vulnerability in Apache Commons VFS before 2.10.0.
The FileObject API in Commons VFS has a 'resolveFile' method that
takes a 'scope' parameter. Specifying 'NameScope.DESCENDENT' promises that "an exception is thrown if the resolved file is not a descendent of
the base file". However, when the path contains encoded ".."
characters (for example, "%2E%2E/bar.txt"), it might return file objects that are not
a descendent of the base file, without throwing an exception.
This issue affects Apache Commons VFS: before 2.10.0.
Users are recommended to upgrade to version 2.10.0, which fixes the issue.
Altre vulnerabilità di org.apache.commons:commons-vfs2
Vedi tutto →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free