In breve
- CVE-2025-30474 è una vulnerabilità MEDIO (CVSS 5.0) che riguarda org.apache.commons:commons-vfs2, commons vfs (apache).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.89%, superiore al 59.4% delle vulnerabilità.
- Correzione: aggiornare a 2.10.0 o successiva.
Description
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Commons VFS.
The FtpFileObject class can throw an exception when a file is not found, revealing the original URI in its message, which may include a password. The fix is to mask the password in the exception message
This issue affects Apache Commons VFS: before 2.10.0.
Users are recommended to upgrade to version 2.10.0, which fixes the issue.
NVD description
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Commons VFS.
The FtpFileObject class can throw an exception when a file is not found, revealing the original URI in its message, which may include a password. The fix is to mask the password in the exception message
This issue affects Apache Commons VFS: before 2.10.0.
Users are recommended to upgrade to version 2.10.0, which fixes the issue.
Altre vulnerabilità di org.apache.commons:commons-vfs2
Vedi tutto →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free