In breve
- CVE-2026-22250 è una vulnerabilità MEDIO (CVSS 5.5) che riguarda wlc, wlc (weblate).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.15%, superiore al 4.5% delle vulnerabilità.
- Correzione: aggiornare a 1.17.0 o successiva.
| Package | Affected versions | Patched versions |
|---|
| wlc PyPI | < 1.17.0
| 1.17.0
|
| wlc | < 1.17.0
| 1.17.0
|
Description
Impact
The SSL verification would be skipped for some crafted URLs.
Patches
Workarounds
Avoid using untrusted wlc configurations, as that might cause insecure connections.
References
This issue was reported to us by wh1zee via HackerOne.
NVD description
wlc is a Weblate command-line client using Weblate's REST API. Prior to 1.17.0, the SSL verification would be skipped for some crafted URLs. This vulnerability is fixed in 1.17.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free