In breve
- CVE-2026-23535 è una vulnerabilità ALTO (CVSS 8.0) che riguarda wlc, wlc (weblate).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.39%, superiore al 32.8% delle vulnerabilità.
- Correzione: aggiornare a 1.17.2 o successiva.
| Package | Affected versions | Patched versions |
|---|
| wlc PyPI | < 1.17.2
| 1.17.2
|
| wlc | < 1.17.2
| 1.17.2
|
Description
Impact
Multi-translation download could write to an arbitrary location when instructed by a crafted server.
Patches
Workarounds
Do not use wlc download with untrusted servers.
References
This issue was reported to us by wh1zee via HackerOne.
NVD description
wlc is a Weblate command-line client using Weblate's REST API. Prior to 1.17.2, the multi-translation download could write to an arbitrary location when instructed by a crafted server. This vulnerability is fixed in 1.17.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free