In breve
- CVE-2026-34972 è una vulnerabilità ALTO (CVSS 8.8) che riguarda github.com/openfga/openfga, helm charts (openfga), openfga (openfga).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.21%, superiore al 11.3% delle vulnerabilità.
- Correzione: aggiornare a 1.14.0, 0.2.62 o successiva.
Description
Description
In OpenFGA, under specific conditions, BatchCheck calls with multiple checks sent for the same object, relation, and user combination can result in improper policy enforcement.
Am I affected?
You are affected if you meet the following preconditions:
- You execute BatchCheck operations which rely on context.
- Multiple checks are sent within a single BatchCheck operation for the same user/object/relation combination, each containing context.
- The contexts between those checks differ in a specific way
Fix
Upgrade to OpenFGA v1.14.0
Acknowledgement
OpenFGA would like to thank @bugbunny-research for the discovery and detailed report.
NVD description
OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. From 1.8.0 to 1.13.1, under specific conditions, BatchCheck calls with multiple checks sent for the same object, relation, and user combination can result in improper policy enforcement. This vulnerability is fixed in 1.14.0.
Altre vulnerabilità di github.com/openfga/openfga
Vedi tutto →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free