In breve
- CVE-2026-82259 è una vulnerabilità ALTO (CVSS 7.5) che riguarda sveltekit (svelte), @sveltejs/kit.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.53%, superiore al 45.0% delle vulnerabilità.
- Correzione: aggiornare a 2.53.3 o successiva.
| Package | Affected versions | Patched versions |
|---|
| sveltekit | ≥ 2.49.0, < 2.53.3
| 2.53.3
|
| @sveltejs/kit npm | ≥ 2.49.0, < 2.53.3
| 2.53.3
|
Description
Some relatively small inputs can cause very large files arrays in form handlers. If the SvelteKit application code doesn't check files.length or individual files' sizes and performs expensive processing with them, it can result in Denial of Service.
Only users with experimental.remoteFunctions: true who are using the form function and are processing the files array without validation are vulnerable.
NVD description
SvelteKit versions from 2.49.0 through 2.53.2 (fixed in 2.53.3) contain a deserialization expansion issue in the experimental form remote function. When an application enables experimental.remoteFunctions and uses the form function to process the files array without validating files.length or individual file sizes, an attacker can submit relatively small inputs that expand into very large file arrays, leading to expensive processing and denial of service.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free