In breve
- CVE-2026-82261 è una vulnerabilità ALTO (CVSS 7.5) che riguarda sveltekit (svelte), @sveltejs/kit.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.49%, superiore al 42.4% delle vulnerabilità.
- Correzione: aggiornare a 2.52.2 o successiva.
| Package | Affected versions | Patched versions |
|---|
| sveltekit | ≥ 2.49.0, < 2.52.2
| 2.52.2
|
| @sveltejs/kit npm | ≥ 2.49.0, < 2.52.2
| 2.52.2
|
Description
Versions of @sveltejs/kit prior to 2.52.2 with remote functions enabled are vulnerable to CPU exhaustion. Malformed form data can cause the server to become unresponsive while processing a request, resulting in denial of service.
Only applications using both experimental.remoteFunctions and form are vulnerable.
NVD description
SvelteKit (@sveltejs/kit) versions >=2.49.0 and <=2.52.1 with experimental remote functions and form enabled contain a CPU exhaustion vulnerability in form deserialization. An attacker can send malformed form data to cause the server to become unresponsive while processing the request, resulting in denial of service. Fixed in 2.52.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free