| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| phpmailer/phpmailer | < 1.7.4 | 1.7.4 |
| phpmailer | = 1.7= 1.7.1= 1.7.2= 1.7.3= 1.73 |
PHPMailer before 1.7.4, when configured to use sendmail, allows remote attackers to execute arbitrary shell commands via shell metacharacters in the SendmailSend function in class.phpmailer.php.
Shell command injection, remotely exploitable if host application does not filter user data appropriately.
Fixed in 1.7.4
Filter and validate user-supplied data before putting in the into the Sender property.
https://nvd.nist.gov/vuln/detail/CVE-2007-3215
If you have any questions or comments about this advisory:
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン