要点
- CVE-2013-6393 は libyaml (pyyaml), openstack (redhat), libyaml に影響する深刻度「中」 (CVSS 6.8) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):7.4%(全脆弱性の 94.4% より高い)。
- 対処:0.2.3 以降に更新してください。
| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|
| libyaml | = 0.0.1= 0.1.1= 0.1.2= 0.1.3≤ 0.1.4
| 修正版なし |
| openstack | = 3.0= 4.0
| 修正版なし |
| libyaml npm | < 0.2.3
| 0.2.3
|
概要
Versions 0.2.2 and earlier depend on native libyaml version 0.1.5 or earlier. As such, they are affected by a heap-based buffer overflow vulnerability that may result in a crash or arbitrary code execution when parsing YAML tags.
Recommendation
- Update to version 0.2.3 that includes a version of LibYAML that contains a fix for this issue.
NVD の説明
The yaml_parser_scan_tag_uri function in scanner.c in LibYAML before 0.1.5 performs an incorrect cast, which allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via crafted tags in a YAML document, which triggers a heap-based buffer overflow.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン