| Package | Affected versions | Patched versions |
|---|---|---|
| react | ≥ 0.4.0, < 0.4.2≥ 0.5.0, < 0.5.2 | 0.4.20.5.2 |
Affected versions of react are vulnerable to Cross-Site Scripting (XSS). The package fails to properly sanitize input used to create keys. This may allow attackers to execute arbitrary JavaScript if a key is generated from user input.
If you are using react 0.5.x, upgrade to version 0.5.2 or later.
If you are using react 0.4.x, upgrade to version 0.4.2 or later.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free