要点
- CVE-2016-10573 は baryton-saxophone (baryton-saxophone project), baryton-saxophone に影響する深刻度「高」 (CVSS 8.1) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):2.0%(全脆弱性の 81.2% より高い)。
- 対処:3.0.1 以降に更新してください。
概要
Affected versions of baryton-saxophone insecurely download an executable over an unencrypted HTTP connection.
In scenarios where an attacker has a privileged network position, it is possible to intercept the response and replace the executable with a malicious one, resulting in code execution on the system running baryton-saxophone.
Recommendation
Update to version 3.0.1 or later.
NVD の説明
baryton-saxophone is a module to install and launch Selenium Server for Mac, Linux and Windows. baryton-saxophone versions below 3.0.1 download binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン