要点
- CVE-2016-10591 は prince (prince project), prince に影響する深刻度「高」 (CVSS 8.1) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):1.7%(全脆弱性の 77.2% より高い)。
- 対処:1.4.6, 1.4.7 以降に更新してください。
| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|
| prince | ≥ 1.4.4, < 1.4.6
| 1.4.6
|
| prince npm | < 1.4.7
| 1.4.7
|
概要
Affected versions of prince insecurely download an executable over an unencrypted HTTP connection.
In scenarios where an attacker has a privileged network position, it is possible to intercept the response and replace the executable with a malicious one, resulting in code execution on the system running prince.
Recommendation
Update to version 1.4.6 or later.
NVD の説明
Prince is a Node API for executing XML/HTML to PDF renderer PrinceXML via prince(1) CLI. prince downloads zipped resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested tarball with an attacker controlled tarball if the attacker is on the network or positioned in between the user and the remote server.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン