要点
- CVE-2016-2515 は hawk (hawk project), hawk に影響する深刻度「高」 (CVSS 7.5) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):3.4%(全脆弱性の 88.8% より高い)。
- 対処:4.1.1, 3.1.3 以降に更新してください。
| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|
| hawk | = 3.1.2= 4.1.0
| 修正版なし |
| hawk npm | ≥ 4.0.0, < 4.1.1< 3.1.3
| 4.1.13.1.3
|
概要
Versions of hawk prior to 3.1.3, or 4.x prior to 4.1.1 are affected by a regular expression denial of service vulnerability related to excessively long headers and URI's.
Recommendation
Update to hawk version 4.1.1 or later.
NVD の説明
Hawk before 3.1.3 and 4.x before 4.1.1 allow remote attackers to cause a denial of service (CPU consumption or partial outage) via a long (1) header or (2) URI that is matched against an improper regular expression.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン