| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| node-simple-router | ≤ 0.10.0 | |
| node-simple-router | < 0.10.1 | 0.10.1 |
Affected versions of node-simple-router resolve relative file paths, resulting in a directory traversal vulnerability. A malicious actor can use this vulnerability to access files outside of the intended directory root, which may result in the disclosure of private files on the vulnerable system.
Example request:
GET /../../../../../../../../../../etc/passwd HTTP/1.1
host:foo
Update to v0.10.1 or later.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン