| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| kreait/firebase-php | ≥ 3.2.0, < 3.8.1 | 3.8.1 |
| firebase admin sdk for php | ≥ 3.2.0, ≤ 3.8.0 |
Jerome Gamez Firebase Admin SDK for PHP version from 3.2.0 to 3.8.0 contains a Incorrect Access Control vulnerability in src/Firebase/Auth/IdTokenVerifier.php does not verify for token signature that can result in JWT with any email address and user ID could be forged from an actual token, or from thin air. This attack appear to be exploitable via Attacker would only need to know email address of the victim on most cases.. This vulnerability appears to have been fixed in 3.8.1.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン