要点
- CVE-2018-1000201 は ffi, ruby-ffi (ruby-ffi project) に影響する深刻度「高」 (CVSS 7.8) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):1.3%(全脆弱性の 71.2% より高い)。
- 対処:1.9.24 以降に更新してください。
| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|
| ffi RubyGems | < 1.9.24
| 1.9.24
|
| ruby-ffi | ≤ 1.9.23
| 修正版なし |
概要
ruby-ffi version 1.9.23 and earlier has a DLL loading issue which can be hijacked on Windows OS, when a Symbol is used as DLL name instead of a String This vulnerability appears to have been fixed in v1.9.24 and later.
NVD の説明
ruby-ffi version 1.9.23 and earlier has a DLL loading issue which can be hijacked on Windows OS, when a Symbol is used as DLL name instead of a String This vulnerability appears to have been fixed in v1.9.24 and later.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン