| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| cryptiles | ≥ 4.1.0, < 4.1.2< 3.1.3 | 4.1.23.1.3 |
| cryptiles | ≥ 3.1.0, < 3.1.3≥ 4.0.0, < 4.1.2 | 3.1.34.1.2 |
Versions of cryptiles prior to 4.1.2 are vulnerable to Insufficient Entropy. The randomDigits() method does not provide sufficient entropy and its generates digits that are not evenly distributed.
Upgrade to version 4.1.2. The package is deprecated and has been moved to @hapi/cryptiles and it is strongly recommended to use the maintained package.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン