要点
- CVE-2018-16491 は node.extend (dreamerslab), node.extend に影響する深刻度「緊急」 (CVSS 9.8) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):1.7%(全脆弱性の 77.6% より高い)。
- 対処:2.0.1, 1.1.7 以降に更新してください。
| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|
| node.extend | ≥ 2.0.0, < 2.0.1< 1.1.7
| 2.0.11.1.7
|
| node.extend npm | ≥ 2.0.0, < 2.0.1< 1.1.7
| 2.0.11.1.7
|
概要
Versions of node.extend before 1.1.7 or 2.0.1 are vulnerable to prototype pollution.
Recommendation
Update to version 1.1.7, 2.0.1 or later.
NVD の説明
A prototype pollution vulnerability was found in node.extend <1.1.7, ~<2.0.1 that allows an attacker to inject arbitrary properties onto Object.prototype.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン