| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| helm.sh/helm | ≥ 2.0.0, < 2.12.2≥ 2.0.0+incompatible, < 2.12.2+incompatible | 2.12.22.12.2+incompatible |
| helm | ≥ 2.0.0, < 2.12.2 | 2.12.2 |
All versions of Helm between Helm >=2.0.0 and < 2.12.2 contains a CWE-22: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in The commands helm fetch --untar and helm lint some.tgz that can result when chart archive files are unpacked a file may be unpacked outside of the target directory. This attack appears to be exploitable via a victim must run a helm command on a specially crafted chart archive. This vulnerability appears to have been fixed in 2.12.2.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン