| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| sequelize | ≥ 3.0.0, < 3.35.1≥ 4.0.0, < 4.44.3≥ 5.0.0, ≤ 5.8.11 | 3.35.14.44.3 |
| sequelize | ≥ 4.0.0, < 4.44.3≥ 5.0.0, < 5.8.11< 3.35.1 | 4.44.35.8.113.35.1 |
Affected versions of sequelize are vulnerable to SQL Injection. The package fails to sanitize JSON path keys in the MariaDB and MySQL dialects, which may allow attackers to inject SQL statements and execute arbitrary SQL queries.
If you are using sequelize 5.x, upgrade to version 5.8.11 or later.
If you are using sequelize 4.x, upgrade to version 4.44.3 or later.
If you are using sequelize 3.x, upgrade to version 3.35.1 or later.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン