| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| sequelize | ≥ 4.0.0, < 4.44.3≥ 5.0.0, < 5.15.1 | 4.44.35.15.1 |
| sequelize | ≥ 5.0.0, < 5.15.1< 4.44.3 | 5.15.14.44.3 |
Affected versions of sequelize are vulnerable to SQL Injection. The function sequelize.json() incorrectly formatted sub paths for JSON queries, which allows attackers to inject SQL statements and execute arbitrary SQL queries if user input is passed to the query. Exploitation example:
return User.findAll({
where: this.sequelize.json("data.id')) AS DECIMAL) = 1 DELETE YOLO INJECTIONS; -- ", 1)
});
If you are using sequelize 5.x, upgrade to version 5.15.1 or later.
If you are using sequelize 4.x, upgrade to version 4.44.3 or later.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン