| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| npm | < 6.13.3 | 6.13.3 |
| graalvm | = 19.3.0.2= 20.3.3= 21.2.2 | |
| npm | < 6.13.3 | 6.13.3 |
Versions of the npm CLI prior to 6.13.3 are vulnerable to an Arbitrary File Write. It fails to prevent access to folders outside of the intended node_modules folder through the bin field. A properly constructed entry in the package.json bin field would allow a package publisher to create files on a user's system when the package is installed. It is only possible to affect files that the user running npm install has access to and it is not possible to over write files that already exist on disk.
This behavior is still possible through install scripts. This vulnerability bypasses a user using the --ignore-scripts install option.
Upgrade to version 6.13.3 or later.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン