| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| psd-tools | ≥ 1.8.37, < 1.9.4< 1.9.4 | 1.9.4 |
| psd-tools | < 1.9.4 | 1.9.4 |
An issue was discovered in psd-tools before 1.9.4. The Cython implementation of RLE decoding did not check for malformed PSD input data during decoding to the PIL.Image or NumPy format, leading to a Buffer Overflow.
Users of psd-tools version v1.8.37 to v1.9.3 should upgrade to v1.9.4.
Without Cython present on installation, buffer overflow does not occur but IndexError will be thrown. However, already installed psd-tools with Cython extention should be upgraded.
https://github.com/psd-tools/psd-tools/pull/198
If you have any questions or comments about this advisory:
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン