| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| spree | ≥ 4.0.0, < 4.0.4≥ 4.1.0, < 4.1.11< 3.7.11 | 4.0.44.1.113.7.11 |
| spree | ≥ 4.0.0, < 4.0.4≥ 4.1.0, < 4.1.11< 3.7.11 | 4.0.44.1.113.7.11 |
The perpetrator who previously obtained an old expired user token could use it to access Storefront API v2 endpoints.
Please upgrade to 3.7.11, 4.0.4, or 4.1.11 depending on your used Spree version.
In your project directory create a decorator file app/controllers/spree/api/v2/base_controller_decotatror.rb with contents:
module Spree
module Api
module V2
module BaseControllerDecorator
private
def spree_current_user
return nil unless doorkeeper_token
return @spree_current_user if @spree_current_user
doorkeeper_authorize!
@spree_current_user ||= ::Spree.user_class.find_by(id: doorkeeper_token.resource_owner_id)
end
end
end
end
Spree::Api::V2::BaseController.prepend(Spree::Api::V2::BaseControllerDecorator)
If you have any questions or comments about this advisory:
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン