Apache Flink Improper Access Control Vulnerability. 悪用が確認されています:CISA は 23/05/2024 にこの脆弱性を「既知の悪用された脆弱性(KEV)」カタログに追加しました。影響を受けるシステムは緊急に修正してください。
| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| org.apache.flink:flink-runtime_2.11 | ≥ 1.11.0, < 1.11.3 | 1.11.3 |
| org.apache.flink:flink-runtime_2.12 | ≥ 1.11.0, < 1.11.3 | 1.11.3 |
| flink | ≥ 1.11.0, < 1.11.3 | 1.11.3 |
A change introduced in Apache Flink 1.11.0 (and released in 1.11.1 and 1.11.2 as well) allows attackers to read any file on the local filesystem of the JobManager through the REST interface of the JobManager process. Access is restricted to files accessible by the JobManager process. All users should upgrade to Flink 1.11.3 or 1.12.0 if their Flink instance(s) are exposed. The issue was fixed in commit b561010b0ee741543c3953306037f00d7a9f0801 from apache/flink:master.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン