| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| org.apache.hadoop:hadoop-yarn-server | ≥ 3.0.0, < 3.2.4≥ 3.3.0, < 3.3.4< 2.10.2 | 3.2.43.3.42.10.2 |
| hadoop | ≥ 2.9.0, < 2.10.2≥ 3.0.0, < 3.2.4≥ 3.3.0, < 3.3.4 | 2.10.23.2.43.3.4 |
ZKConfigurationStore which is optionally used by CapacityScheduler of Apache Hadoop YARN deserializes data obtained from ZooKeeper without validation. An attacker having access to ZooKeeper can run arbitrary commands as YARN user by exploiting this. Users should upgrade to Apache Hadoop 2.10.2, 3.2.4, 3.3.4 or later (containing YARN-11126) if ZKConfigurationStore is used.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン