| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| apache-airflow | ≥ 1.8.1, < 1.10.15≥ 2.0.0, < 2.0.2≥ 2.0.0a1, < 2.0.2< 1.10.15 | 1.10.152.0.2 |
| airflow | ≥ 1.0.0, < 1.10.15≥ 2.0.0, < 2.0.2 | 1.10.152.0.2 |
The "origin" parameter passed to some of the endpoints like '/trigger' was vulnerable to XSS exploit. This issue affects Apache Airflow versions <1.10.15 in 1.x series and affects 2.0.0 and 2.0.1 and 2.x series. This is the same as CVE-2020-13944 & CVE-2020-17515 but the implemented fix did not fix the issue completely. Update to Airflow 1.10.15 or 2.0.2. Please also update your Python version to the latest available PATCH releases of the installed MINOR versions, example update to Python 3.6.13 if you are on Python 3.6. (Those contain the fix for CVE-2021-23336 https://nvd.nist.gov/vuln/detail/CVE-2021-23336).
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン