| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| ghost | ≥ 4.0.0, < 4.10.0 | 4.10.0 |
| ghost | ≥ 4.0.0, < 4.10.0 | 4.10.0 |
An error in the implementation of the limits service in 4.0.0 allows all authenticated users (including contributors) to view admin-level API keys via the integrations API endpoint, leading to a privilege escalation vulnerability.
Ghost(Pro) has already been patched. Self-hosters are impacted if running Ghost a version between 4.0.0 and 4.9.4. Immediate action should be taken to secure your site - see patches & workarounds below.
It is highly recommended to regenerate all API keys after patching or applying the workaround below.
Fixed in 4.10.0, all 4.x sites should upgrade as soon as possible.
If you have any questions or comments about this advisory:
Credits: Aden Yap Chuen Zhen, BAE Systems Applied Intelligence (Malaysia)
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン