要点
- CVE-2021-41134 は nbdime, nbdime (jupyter), nbdime-jupyterlab (jupyter) に影響する深刻度「中」 (CVSS 5.4) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):0.70%(全脆弱性の 53.3% より高い)。
- 対処:2.1.1, 3.1.1, 1.1.1, 5.0.2 以降に更新してください。
| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|
| nbdime PyPI | ≥ 2.0.0, < 2.1.1≥ 3.0.0, < 3.1.1< 1.1.1
| 2.1.13.1.11.1.1
|
| nbdime | ≥ 1.0.0, < 1.1.1≥ 2.0.0, < 2.1.1≥ 3.0.0, ≤ 3.1.1≥ 5.0.0, < 5.0.2≥ 6.0.0, < 6.1.2
| 1.1.12.1.15.0.26.1.2
|
| nbdime-jupyterlab | ≥ 1.0.0, < 1.0.1≥ 2.0.0, < 2.1.1
| 1.0.12.1.1
|
| nbdime npm | ≥ 6.0.0, < 6.1.2< 5.0.2
| 6.1.25.0.2
|
| nbdime-jupyterlab npm | ≥ 2.0.0, < 2.1.1< 1.0.1
| 2.1.11.0.1
|
概要
Impact
Improper handling of user controlled input caused a stored cross-site scripting (XSS) vulnerability. All previous versions of nbdime are affected.
Patches
Security patches will be released for each of the major versions of the nbdime packages since version 1.x of the nbdime python package.
Python
- nbdime 1.x: Patched in v. 1.1.1
- nbdime 2.x: Patched in v. 2.1.1
- nbdime 3.x: Patched in v. 3.1.1
npm
- nbdime 6.x version: Patched in 6.1.2
- nbdime 5.x version: Patched in 5.0.2
- nbdime-jupyterlab 1.x version: Patched in 1.0.1
- nbdime-jupyterlab 2.x version: Patched in 2.1.1
For more information
If you have any questions or comments about this advisory email us at [email protected].
NVD の説明
nbdime provides tools for diffing and merging of Jupyter Notebooks. In affected versions a stored cross-site scripting (XSS) issue exists within the Jupyter-owned nbdime project. It appears that when reading the file name and path from disk, the extension does not sanitize the string it constructs before returning it to be displayed. The diffNotebookCheckpoint function within nbdime causes this issue. When attempting to display the name of the local notebook (diffNotebookCheckpoint), nbdime appears to simply append .ipynb to the name of the input file. The NbdimeWidget is then created, and the base string is passed through to the request API function. From there, the frontend simply renders the HTML tag and anything along with it. Users are advised to patch to the most recent version of the affected product.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン