| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| express openid connect | ≥ 2.3.0, < 2.5.2 | 2.5.2 |
| express-openid-connect | ≥ 2.3.0, < 2.5.2 | 2.5.2 |
Versions 2.3.0 up to and including 2.5.1 do not regenerate the session id and session cookie when user logs in. This behavior opens up the application to various session fixation vulnerabilities.
You are affected by this vulnerability if you are using express-openid-connect version 2.3.0 up to and including 2.5.1 and use a custom session store.
Upgrade to version >= 2.5.2.
The fix provided in patch will not affect your users.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン