要点
- CVE-2021-4231 は angular (angular), angularjs (angularjs), @angular/core に影響する深刻度「中」 (CVSS 5.4) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):1.2%(全脆弱性の 67.7% より高い)。
- 対処:11.0.5, 11.1.0-next.3, 10.2.5 以降に更新してください。
| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|
| angular | = 11.1.0
| 修正版なし |
| angularjs | < 11.0.5
| 11.0.5
|
| @angular/core npm | ≥ 11.0.0, < 11.0.5≥ 11.1.0-next.0, < 11.1.0-next.3< 10.2.5
| 11.0.511.1.0-next.310.2.5
|
概要
A vulnerability was found in Angular up to 11.0.4/11.1.0-next.2. It has been classified as problematic. Affected is the handling of comments. The manipulation leads to cross site scripting. It is possible to launch the attack remotely but it might require an authentication first. Upgrading to version 10.2.5, 11.0.5 or 11.1.0-next.3 is advised to to address this issue.
NVD の説明
A vulnerability was found in Angular up to 11.0.4/11.1.0-next.2. It has been classified as problematic. Affected is the handling of comments. The manipulation leads to cross site scripting. It is possible to launch the attack remotely but it might require an authentication first. Upgrading to version 11.0.5 and 11.1.0-next.3 is able to address this issue. The name of the patch is ba8da742e3b243e8f43d4c63aa842b44e14f2b09. It is recommended to upgrade the affected component.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン