要点
- CVE-2022-21705 は october/system, october (octobercms) に影響する深刻度「高」 (CVSS 7.2) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):8.6%(全脆弱性の 95.1% より高い)。
- 対処:1.1.10, 2.1.27, 1.0.474 以降に更新してください。
| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|
| october/system Packagist | ≥ 1.1.0, < 1.1.10≥ 2.0.0, < 2.1.27< 1.0.474
| 1.1.102.1.271.0.474
|
| october | ≥ 1.1.0, < 1.1.10≥ 2.0.0, < 2.1.27< 1.0.474
| 1.1.102.1.271.0.474
|
概要
Impact
An authenticated user with the permissions to create, modify and delete website pages can exploit this vulnerability to bypass cms.safe_mode / cms.enableSafeMode in order to execute arbitrary code.
- This issue only affects admin panels that rely on safe mode and restricted permissions.
- To exploit this vulnerability, an attacker must first have access to the backend area.
Patches
The issue has been patched in Build 474 (v1.0.474) and v1.1.10.
Workarounds
Apply https://github.com/octobercms/library/commit/c393c5ce9ca2c5acc3ed6c9bb0dab5ffd61965fe to your installation manually if unable to upgrade to Build 474 or v1.1.10.
References
Credits to:
For more information
If you have any questions or comments about this advisory:
NVD の説明
Octobercms is a self-hosted CMS platform based on the Laravel PHP Framework. In affected versions user input was not properly sanitized before rendering. An authenticated user with the permissions to create, modify and delete website pages can exploit this vulnerability to bypass `cms.safe_mode` / `cms.enableSafeMode` in order to execute arbitrary code. This issue only affects admin panels that rely on safe mode and restricted permissions. To exploit this vulnerability, an attacker must first have access to the backend area. The issue has been patched in Build 474 (v1.0.474) and v1.1.10. Users unable to upgrade should apply https://github.com/octobercms/library/commit/c393c5ce9ca2c5acc3ed6c9bb0dab5ffd61965fe to your installation manually.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン