| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| activestorage | ≥ 5.2.0, < 5.2.6.3≥ 6.0.0, < 6.0.4.7≥ 6.1.0, < 6.1.4.7≥ 7.0.0, < 7.0.2.3 | 5.2.6.36.0.4.76.1.4.77.0.2.3 |
| active storage | ≥ 5.2.0, < 5.2.6.3≥ 6.0.0, < 6.0.4.7≥ 6.1.0, < 6.1.4.7≥ 7.0.0, < 7.0.2.3 | 5.2.6.36.0.4.76.1.4.77.0.2.3 |
The Active Storage module of Rails starting with version 5.2.0 is possibly vulnerable to code injection. This issue was patched in versions 5.2.6.3, 6.0.4.7, 6.1.4.7, and 7.0.2.3. To work around this issue, applications should implement a strict allow-list on accepted transformation methods or arguments. Additionally, a strict ImageMagick security policy will help mitigate this issue.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン