要点
- CVE-2022-23499 は typo3/cms, typo3/html-sanitizer, html sanitizer (typo3) に影響する深刻度「中」 (CVSS 6.1) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):0.47%(全脆弱性の 40.5% より高い)。
- 対処:10.4.33, 11.5.20, 12.1.1, 1.5.0 以降に更新してください。
| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|
| typo3/cms Packagist | ≥ 10.0.0, < 10.4.33≥ 11.0.0, < 11.5.20≥ 12.0.0, < 12.1.1
| 10.4.3311.5.2012.1.1
|
| typo3/html-sanitizer Packagist | ≥ 1.0.0, < 1.5.0≥ 2.0.0, < 2.1.1
| 1.5.02.1.1
|
| html sanitizer | ≥ 1.0.0, ≤ 1.0.7≥ 2.0.0, < 2.1.1
| 2.1.1
|
概要
Problem
Due to a parsing issue in the upstream package masterminds/html5, malicious markup used in a sequence with special HTML CDATA sections cannot be filtered and sanitized. This allows bypassing the cross-site scripting mechanism of typo3/html-sanitizer.
Besides that, the upstream package masterminds/html5 provides HTML raw text elements (script, style, noframes, noembed and iframe) as DOMText nodes, which were not processed and sanitized further. None of the mentioned elements were defined in the default builder configuration, that's why only custom behaviors, using one of those tag names, were vulnerable to cross-site scripting.
Solution
Update to typo3/html-sanitizer versions 1.5.0 or 2.1.1 that fix the problem described.
NVD の説明
HTML sanitizer is written in PHP, aiming to provide XSS-safe markup based on explicitly allowed tags, attributes and values. In versions prior to 1.5.0 or 2.1.1, malicious markup used in a sequence with special HTML CDATA sections cannot be filtered and sanitized due to a parsing issue in the upstream package masterminds/html5. This allows bypassing the cross-site scripting mechanism of typo3/html-sanitizer. The upstream package masterminds/html5 provides HTML raw text elements (`script`, `style`, `noframes`, `noembed` and `iframe`) as DOMText nodes, which were not processed and sanitized further. None of the mentioned elements were defined in the default builder configuration, that's why only custom behaviors, using one of those tag names, were vulnerable to cross-site scripting. This issue has been fixed in versions 1.5.0 and 2.1.1.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン