要点
- CVE-2022-23505 は passport-wsfed-saml2 (auth0), passport-wsfed-saml2 に影響する深刻度「高」 (CVSS 7.5) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):0.80%(全脆弱性の 56.6% より高い)。
- 対処:4.6.3 以降に更新してください。
概要
Overview
A remote attacker can bypass WSFed authentication on a website using passport-wsfed-saml2. A successful attack requires that the attacker is in possession of an arbitrary IDP signed WSFed assertion. Depending on the IDP used, fully unauthenticated attacks (e.g without access to a valid user) might also be feasible if generation of a signed message can be triggered.
Am I affected?
You are affected if you are using WSFed protocol with the passport-wsfed-saml2 library versions < 4.6.3.
SAML2 protocol is not affected.
How do I fix it?
Upgrade the library to version 4.6.3.
Will the fix impact my users?
No, the fix will not impact your users.
NVD の説明
Passport-wsfed-saml2 is a ws-federation protocol and SAML2 tokens authentication provider for Passport. In versions prior to 4.6.3, a remote attacker may be able to bypass WSFed authentication on a website using passport-wsfed-saml2. A successful attack requires that the attacker is in possession of an arbitrary IDP signed assertion. Depending on the IDP used, fully unauthenticated attacks (e.g without access to a valid user) might also be feasible if generation of a signed message can be triggered. This issue is patched in version 4.6.3. Use of SAML2 authentication instead of WSFed is a workaround.
passport-wsfed-saml2 のその他の脆弱性
すべて見る →これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン