要点
- CVE-2022-24710 は weblate, weblate (weblate) に影響する深刻度「中」 (CVSS 5.4) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):0.75%(全脆弱性の 55.1% より高い)。
- 対処:4.11 以降に更新してください。
概要
Impact
Due to improper neutralization, it was possible to perform cross-site scripting via crafted user and language names.
Patches
The issues were fixed in the 4.11 release. The following commits are addressing it:
- f6753a1a1c63fade6ad418fbda827c6750ab0bda
- 9e19a8414337692cc90da2a91c9af5420f2952f1
- 22d577b1f1e88665a88b4569380148030e0f8389
Workarounds
You can look for crafted user and language names to see if you were affected.
References
For more information
If you have any questions or comments about this advisory:
NVD の説明
Weblate is a copyleft software web-based continuous localization system. Versions prior to 4.11 do not properly neutralize user input used in user name and language fields. Due to this improper neutralization it is possible to perform cross-site scripting via these fields. The issues were fixed in the 4.11 release. Users unable to upgrade are advised to add their own neutralize logic.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン