| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| Moment.js | < 2.29.2 | 2.29.2 |
| moment | ≥ 1.0.1, < 2.29.2 | 2.29.2 |
| tenable.sc | < 5.21.0 | 5.21.0 |
| moment | < 2.29.2 | 2.29.2 |
This vulnerability impacts npm (server) users of moment.js, especially if user provided locale string, eg fr is directly used to switch moment locale.
This problem is patched in 2.29.2, and the patch can be applied to all affected versions (from 1.0.1 up until 2.29.1, inclusive).
Sanitize user-provided locale name before passing it to moment.js.
Are there any links users can visit to find out more?
If you have any questions or comments about this advisory:
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン