要点
- CVE-2022-24800 は october/system, october (octobercms) に影響する深刻度「高」 (CVSS 8.1) の脆弱性です。
- 今後30日間に悪用される確率(EPSS):1.5%(全脆弱性の 73.6% より高い)。
- 対処:1.1.12, 2.2.15, 1.0.476 以降に更新してください。
| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|
| october/system Packagist | ≥ 1.1.0, < 1.1.12≥ 2.0.0, < 2.2.15< 1.0.476
| 1.1.122.2.151.0.476
|
| october | ≥ 1.1.0, < 1.1.12≥ 2.0.0, < 2.2.15< 1.0.476
| 1.1.122.2.151.0.476
|
概要
Impact
This advisory affects plugins that expose the October\Rain\Database\Attach\File::fromData as a public interface. This vulnerability does not affect vanilla installations of October CMS since this method is not exposed or used by the system internally or externally.
When the developer allows the user to specify their own filename in the fromData method, an unauthenticated user can perform remote code execution (RCE) by exploiting a race condition in the temporary storage directory.
Patches
The issue has been patched in Build 476 (v1.0.476) and v1.1.12 and v2.2.15.
Workarounds
Apply https://github.com/octobercms/library/commit/fe569f3babf3f593be2b1e0a4ae0283506127a83 to your installation manually if unable to upgrade to Build 476 (v1.0.476) or v1.1.12 or v2.2.15.
References
Credits to:
- DucNT, HungTD and GiangVQ from RedTeam@VNG Security Response Center.
For more information
If you have any questions or comments about this advisory:
NVD の説明
October/System is the system module for October CMS, a self-hosted CMS platform based on the Laravel PHP Framework. Prior to versions 1.0.476, 1.1.12, and 2.2.15, when the developer allows the user to specify their own filename in the `fromData` method, an unauthenticated user can perform remote code execution (RCE) by exploiting a race condition in the temporary storage directory. This vulnerability affects plugins that expose the `October\Rain\Database\Attach\File::fromData` as a public interface and does not affect vanilla installations of October CMS since this method is not exposed or used by the system internally or externally. The issue has been patched in Build 476 (v1.0.476), v1.1.12, and v2.2.15. Those who are unable to upgrade may apply with patch to their installation manually as a workaround.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン