| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| Yarp.ReverseProxy | ≥ 1.1.0-rc.1.22152.1, < 1.1.0-rc.1.22211.2< 1.0.1 | 1.1.0-rc.1.22211.21.0.1 |
| yet another reverse proxy | = 1.0.0= 1.1.0 |
A denial of service vulnerability exists in how YARP processes input.
If you're using YARP 1.0.0, you should update to NuGet package version 1.0.1.
If you're using YARP 1.1.0-RC.1, you should update to NuGet package version 1.1.0-rc.1.22211.2.
You can do so by updating the PackageReference in your .csproj file
<ItemGroup>
- <PackageReference Include="Yarp.ReverseProxy" Version="1.0.0" />
- <PackageReference Include="Yarp.Telemetry.Consumption" Version="1.0.0" />
+ <PackageReference Include="Yarp.ReverseProxy" Version="1.0.1" />
+ <PackageReference Include="Yarp.Telemetry.Consumption" Version="1.0.1" />
</ItemGroup>
or by selecting 1.0.1 in the NuGet UI inside Visual Studio (Manage NuGet Packages / Updates)
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン