| パッケージ | 影響を受けるバージョン | 修正済みバージョン |
|---|---|---|
| net.sourceforge.htmlunit:neko-htmlunit | < 2.27 | 2.27 |
| antisamy | < 1.6.6 | 1.6.6 |
| cyberneko html | ≤ 1.9.22 | |
| htmlunit | < 2.27 | 2.27 |
Certain Neko-related HTML parsers allow a denial of service via crafted Processing Instruction (PI) input that causes excessive heap memory consumption. In particular, this issue exists in HtmlUnit-Neko through 2.26, and is fixed in 2.27. This issue also exists in CyberNeko HTML through 1.9.22 (also affecting OWASP AntiSamy before 1.6.6), but 1.9.22 is the last version of CyberNeko HTML. NOTE: this may be related to CVE-2022-24939.
これらの製品をお使いですか?サイトをスキャンして、脆弱なバージョンが公開されていないか確認しましょう。
無料でサイトをスキャン